WordPress 5.6 update problemen én oplossingen

Grote update in WordPress 5.6 maak eerst een backup

WP 5.6 bevat een grote update aan de jQuery library zorg dat je een backup maakt voorafgaand aan het updaten of de update eerst test in een testomgeving!

In WordPress 5.5 was er een aanpassing waarbij jQuery Migrate helper script standaard niet meer ingeladen werd. Met WordPress versie 5.6 zal de gebundelde jQuery versie een upgrade krijgen van versie 1.12.4 naar jQuery 3.5.1
Dit kan problemen geven bij verouderde thema’s en plugins of die achterlopen met updates.

In het beste geval zullen sommige onderdelen niet meer werken, in het slechtste geval kan dit een fatale error veroorzaken waardoor ook alle andere jQuery en javascript code in de website niet meer functioneert.
Een tijdelijke oplossing hiervoor is om de Enable jQuery Migrate Helper plugin te installeren.
Dit is met nadruk een tijdelijke oplossing aangezien de oudere jQuery versie ook geen beveiligingsupdates meer krijgt.

Wanneer geactiveerd zal deze plugin meldingen geven van de verouderde code die gesignaleerd wordt, dat is alleen zichtbaar voor jou als ingelogde gebruiker en niet voor je bezoekers.

WordPress laten updaten door specialisten zonder risico te lopen?
Bekijk onze onderhoud & service pakketten

WordPress onderhoud uitbesteden

Wat is er nieuw in WordPress 5.6

  • Ondersteuning voor PHP 8
  • Nieuw default thema “Twenty Twenty-one”
  • Ondersteuning voor ‘Block patronen’ thema’s kunnen nu standaard pagina’s en elementen maken die jij kan gebruiken in de blokken bewerker (Gutenberg)
  • Bijschriften en ondertiteling in video’s
  • Video achtergronden in het ‘cover’ / omslag blok
  • Automatische updates verder uitgebreid, Vanaf nu is het ook mogelijk om WordPress core automatisch te laten updaten. (dit kan bij sommige hosting providers en in combinatie met betaalde thema’s en plugins problemen geven op termijn)
  • jQuery versie update, dit kan problemen geven icm pagebuilders, thema’s en plugins die niet volledig zijn bijgewerkt.
  • En nog veel meer, zie alle wijzigingen in de 5.6 field guide

WordPress laten updaten door specialisten zonder risico te lopen?
Bekijk onze onderhoud & service pakketten

WordPress onderhoud uitbesteden

WordPress 5.0

Kijk onderstaand Webinar terug hoe je een back-up maakt en veilig kan testen of deze nieuwe versie problemen veroorzaakt voor jouw website.
We maken in onderstaande video gebruik van de tool & plugin van Blogvault om de website te back-uppen en een testversie op te zetten.

WordPress 5.0 uitleg

Begin dit jaar hadden we al een aantal uitleg video’s opgenomen met een vroege testversie van de nieuwe WordPress Block-editor (blokken bewerker)
Die uitleg kan je hier terug vinden:

Veel gestelde vragen over WordPress 5.0

Mijn website is volledig wit blanco / 500 foutmelding

Waarschijnlijk is de update niet volledig goed gegaan, je kan proberen de update handmatig opnieuw te installeren of de debug stappen volgen in dit artikel over de generieke php 500 foutmelding.
Een backup herstellen van voor de update is waarschijnlijk het snelste als je zelf niet heel technisch bent.

Ik kan de teksten op mijn pagina’s en berichten niet meer aanpassen! Het ziet er totaal anders uit!

Je kan de Classic Editor plugin installeren om weer terug te gaan naar de oude editor.
Deze plugin wordt tot 2022 ondersteund volgens de huidige planning.
Verouderde webbrowsers kunnen ook problemen veroorzaken

Mijn website ziet er ‘vreemd uit’

Dit kan een cache probleem zijn. Leeg de cache van een caching plugin als je die gebruikt. Daarnaast kan het voorkomen dat bij sommige webhosting providers de cache ook ge-‘flushed’ moet worden.

 

Kan ik na het updaten naar WordPress 5 nog terug? /
Kan ik nog terug naar de oude WordPress editor?

Het ‘downgraden’ van een WordPress installatie raad ik af, als je een backup hebt van de website dan zou je die wel kunnen herstellen.
Anders is het installeren van de Classic Editor plugin de beste oplossing

Veranderd het updaten naar WordPress 5 mijn bestaande berichten en pagina’s?

Nee, bestaande berichten en pagina inhoud wordt in een ‘classic blok’ geplaatst. Er is per pagina/bericht een handmatige actie nodig om die om te zetten naar de structuur van de nieuwe editor.

Kan ik bestaand pagina’s & berichten aanpassen in de nieuwe editor?

Ja dat is mogelijk.

Ik maak gebruik van een page-builder, kan ik veilig updaten?

Wees hiermee heel heel voorzichtig en test dit eerst in een veilige test-omgeving en zorg dat je een backup hebt van je website. Controleer ook handmatig of je thema en pagebuilder de laatste versie zijn. Zoeken in Google op “Thema-naam changelog” of de pagina van de verkoper en kijk of de versie nummers overeen komen. Als het betaalde thema de afgelopen 6 maanden geen update heeft gehad is het risico nog groter.

Hoe plaats ik afbeeldingen naast de tekst?

Hiervoor zijn twee mogelijkheden. je kan het specifieke ‘media & tekst’ blok gebruiken of een afbeelding blok plaatsen voor het tekstblok en daar de uitlijning van aanpassen.

Blijven mijn plugins werken wanneer ik update naar WordPress 5.0?

De meeste plugins die goed onderhouden worden en up-to-date zijn zullen blijven werken. Sommige plugins zullen zelfs nieuwe functies en blokken toevoegen speciaal voor WordPress versie 5.0 en later.

WordPress toont alleen code wanneer ik een bericht of pagina probeer te bewerken?

Ga naar je profiel en zet het vinkje bij Visuele editor “De visuele editor uitschakelen tijdens het schrijven” uit. Als het goed is zou je nu van de nieuwe bewerker gebruik kunnen maken.